
Installing Office 2000 in a Windows Terminal Server Environment  

You install Microsoft Office 2000 from Microsoft Office 2000 Disc 1 on a Microsoft Windows Terminal Server 
computer in much the same way you install Office on a client computer. With some careful planning and a few 
modifications, Office performs well in the Windows Terminal Server environment.  

To run Office 2000 in this environment, follow these steps: 
1.  Customize the Terminal Server transform (MST file).  
2.  Install Office on the Terminal Server computer.  

3.  Set default Office application settings for Windows Terminal Client users.  
4.  Configure Microsoft Outlook 2000.  
Running Office on individual users’ computers is different from running it in a Terminal Server environment. 
When you install Office on a Terminal Server computer, the users who connect to the server are limited to your 
Office configuration and cannot install or remove features.  
In other words, all users running Office from the Terminal Server computer inherit the features you select during 
installation. If your users need different sets of Office functionality, you might need several Terminal Server 
computers — one for each unique Office configuration.  
Because of the multiuser nature of the Terminal Server computer, and users’ restricted access to the server, you 
cannot select the following installation options for any Office features: 
1.  Run from CD or Run from Network  
2.  Run all from CD or Run all from Network  

3.  Installed on First Use  
Instead, you must predetermine which Office features your users need and select one of the following installation 
options for each feature:  

1.  Run from My Computer  
2.  Run all from My Computer  
3.  Not Available  

Customize the Terminal Server transform 
   

The Microsoft Office 2000 Resource Kit includes a Windows installer transform that you must use when installing 
Office on the Terminal Server computer – Setup does not install Office on the Terminal Server computer without 
the transform. This transform, named TermSrvr.mst, is configured to install all Office features to run from the 
local computer or not be installed at all. 
Toolbox   Because of the special requirements for running Office in a Windows Terminal Server environment, 
you must use the transform provided in the Office Resource Kit to install Office on the Terminal Server computer. 
Office Setup does not install Office on the Terminal Server computer without this transform. For information about 
installing TermSrvr.mst, see Office 2000 Resource Kit Toolbox. 

What the TermSrvr.mst file does 
The Windows installer transform included in the Office Resource Kit, TermSrvr.mst, is configured to install Office 
correctly on the Terminal Server computer. Office Setup does not install Office on the Terminal Server computer 
without this transform. 
The primary function of the TermSrvr.mst file is to modify the feature tree so that all Office features are installed 
to run from the local computer. There are a few exceptions – those features that are not recommended or that do 
not perform well in the Terminal Server environment are set to not be installed at all. 
In addition, the NOUSERNAME property is set so that Setup does not supply a default user name when you 
install Office on the Terminal Server computer. This setting ensures that users who log on to the Terminal Server 
computer are asked to provide a user name when they run an Office application for the first time. This property is 
set internally in the transform – if you examine the transform with the Custom Installation Wizard, you do not see 
the NOUSERNAME property listed on the Modify Setup Properties panel. 

The TermSrvr.mst file also sets a property to increase the amount of registry space allocated for Office on the 
Terminal Server computer. This setting allows Office to store necessary information in the registry for each Office 
user. Again, this property is not listed on the Modify Setup Properties panel. 

In the TermSrvr.mst file, all Office features are set to one of the following installation states: 
1.  Most features are set to Run from My Computer.  



 These are features that work well in the Terminal Server environment.  
2.  A few features are set to Not Available.  

 These are features that do not perform well in the Terminal Server environment, typically because they use 
additional animation that generates excess data traffic between the Terminal Server computer and the 
Terminal Client computer. Consider leaving these features set to Not Available so that they are not installed.  

3.  A few features are set to both Not Available and Hidden.  
 These features do not work under Terminal Server because they rely on capabilities not available in this 

environment or they require write access to restricted areas of the Terminal Server computer. Leave these 
features set to Not Available so that they are not installed on the Terminal Server computer.  

4.  Some features are set to Run from My Computer and Hidden.  
 These are features that are normally hidden in the Office Setup feature tree, but they have been exposed in 

the Custom Installation Wizard so that you can choose whether you want to install them.  
Toolbox   A number of Outlook features, normally hidden in the Office Setup feature tree, are exposed in the 
Terminal Server transform. This arrangement allows you to choose whether to install these features. The Office 
Resource Kit includes an Excel worksheet named OutlFeat.xls that describes these Outlook features. For 
information about installing OutlFeat.xls, see Office 2000 Resource Kit Toolbox. 
If you want to accept the default Office configuration, you do not need to modify TermSrvr.mst. However, if there 
are Office features that are not needed by your users, you can improve overall performance and conserve disk 
space by customizing TermSrvr.mst so that Office Setup does not install these features on the Terminal Server 
computer.  

Installing nonEnglish versions of Office  
The TermSrvr.mst file was created using the Windows installer package (Data1.msi) for the US English version 
of Office 2000. Some other language versions of Office have additional features that are not present in the US 
English version, and the TermSrvr.mst file does not change the installation states of those features. If any of 
these additional features are set to Run from Network or Installed on First Use , then they do not function 
correctly on the Terminal Server computer.  

To install a nonEnglish version of Office on a Terminal Server computer, use the Office Custom Installation 
Wizard to make sure that all features in the transform are set to either Run from My Computer or Not 
Available. 

To customize the Terminal Server transform  
1.  Start the Office Custom Installation Wizard.  
2.  On the Open the MSI File panel, specify the Office MSI file, Data1.msi.  

3.  On the Open the MST File panel, select Open an existing MST file and enter the file name and path of the 
TermSrvr.mst file.  

4.  On the Select the MST File to Save  panel, enter the file name and path of the TermSrvr.mst file.  

 If you do not want to modify the original MST file, then you can enter a new file name for the wizard to create.  
5.  On the Set Feature Installation States panel, set unneeded features to Not Available.  
 Make sure that all features that you want to install are set to Run from My Computer.  

6.  If you are installing Outlook, under Microsoft Outlook for Windows\OutlookMessaging, select either 
OutlookMAPI or OutlookOMI; set one feature to Run from My Computer and the other feature to Not 
Available.  

7.  On the Customize Outlook Installation Options panel, select Customize Outlook profile and account 
information and set Configuration Type to either Corporate or Workgroup Settings or Internet Only 
Settings.  

 This choice must match your choice in Step 5. If you select OutlookMAPI, you must select Corporate or 
Workgroup Settings; if you select OutlookOMI, you must select Internet Only Settings. Because users 
are restricted in how they can configure the Terminal Server computer after installation, you must make this 
selection during installation.  

8.  On the remainder of the panels, make additional customizations to tailor the Office installation on the 
Terminal Server computer.  

 For example, to fully customize how Internet Explorer 5 is installed, click Customize on the Customize IE5 
Installation Options panel.  



Toolbox   By default, the Terminal Server transform (TermSrvr.mst) does not install any Office Assistants. 
However, after running Office Setup you can install the Motionless Office Assistant (Stillogo.acs) included in the 
Office Resource Kit. This Office Assistant uses no animation, so there is minimal network traffic between the 
Terminal Server computer and the Terminal Client computer. For information about installing the Motionless 
Office Assistant, see see Terminal Server Tools in theOffice 2000 Resource Kit Toolbox. 

Install Office on the Terminal Server computer 
   

To install Office, run Office Setup on the Terminal Server computer. You can run Setup from a network 
administrative installation point or from the Office Disc 1. You must specify the Terminal Server transform 
(TermSrvr.mst) and additional command-line options. 

Note   Before you install Office on a Terminal Server computer, log on to the server with administrator privileges. 
To install Office Disc 1 on the Terminal Server computer  
1.  In Control Panel, double-click Add/Remove Programs, click Install, and then click Next.  

2.  Click Browse .  
3.  In the root folder of the Office Disc 1, select setup.exe and click OK.  
 Setup.exe is added to the Command line for installation program box.  

4.  On the command line, add the following two commands after setup.exe, separated by spaces:  
 TRANSFORMS="path\TermSrvr.mst"  
 This command identifies the Terminal Server transform for Setup to use during installation. Specify the 

correct path to the MST file.  
 /l* "%WINDIR%\Office 2000 Setup(0001).txt"  
 This optional command places the Setup log file in the Windows folder, rather than in the %TEMP% folder, 

so that it is not deleted automatically by Windows.  
5.  Click Next  
6.  In Add/Remove Programs, select All users begin with common application settings, and then click Next 

to run Office Setup.  
Important   You must use Add/Remove Programs in Control Panel with the All users begin with common 
application settings option selected. This setting runs Setup in Install mode, which installs Office for all 
Terminal Client users who connect to the Terminal Server computer. If you run Setup directly from Office Disc 1, 
then Setup runs in Execute mode, which installs Office only for the user running Setup.  

Set default Office application settings 
   

You can use the Profile Wizard to customize the default Office user settings for all users logging on to the 
Terminal Server computer. For best performance in this environment, consider setting the following options in 
Office applications. 

Microsoft Access 2000 
   

1.  On the Tools menu, click Customize, and then click the Options tab. Set the Menu animations option to 
None.  

2.  On the Tools menu and then click Customize. Remove the Detect and Repair command from the Help 
menu.  

3.  On the Tools menu, click Options,  and then click the General tab. Clear the Provide feedback with sound 
check box.  

Microsoft Excel 2000 
   

1.  On the Tools menu, click Customize and then click the Options tab. Set the Menu animations option to 
None.  

2.  On the Tools menu and then click Customize. Remove the Detect and Repair command from the Help 
menu.  

3.  On the Tools menu, click Options,  and then click the Edit tab. Clear the Provide feedback with animation 
check box.  

4.  On the Tools menu, click Options,  and then click the General tab. Clear the Provide feedback with sound 
check box.  



Microsoft FrontPage 2000 
   

1.  On the Tools menu, click Customize, and then click the Options tab. Set the Menu animations option to 
None.  

Microsoft Outlook 2000 
   

1.  On the Tools menu, click Customize, and then click the Options tab. Set the Menu animations option to 
None.  

2.  On the Tools menu, click Customize, and then click the Commands tab. Remove the Save as Web Page  
command from the File menu, and remove the Detect and Repair command from the Help menu.  

3.  On the Tools menu, click Options, and then click the Other tab. Click Advanced Options and clear the 
Provide feedback with sound check box.  

4.  On the Tools menu, click Options, and then click the Preferences tab. Click E-mail Options and clear the 
Display a notification message when new mail arrives check box.  

5.  On the Tools menu, click Options, and then click the Preferences tab. Click E-mail Options, click 
Advanced E-mail Options, and clear the Play a sound and Briefly change the mouse cursor check 
boxes.  

6.  On the Tools menu, click Options, and then click the Preferences tab. Click Calendar Options and clear 
the Use Microsoft Schedule+ as my primary calendar check box.  

Microsoft PowerPoint 2000 
   

1.  On the Tools menu, click Customize and then click the Options tab. Set the Menu animations option to 
None.  

2.  On the Tools menu and then click Customize. Remove the Detect and Repair command from the Help 
menu.  

3.  On the Tools menu, click Options,  and then click the General tab. Clear the Provide feedback with sound 
to screen elements check box.  

4.  On the Tools menu, click Options, and then click the Spelling and Style tab. Clear the Check spelling as 
you type check box.  

5.  On the Tools menu, click Options, and then click the General tab. Click Web Options, click the General 
tab, and clear the Show slide animation while browsing check box.  

Microsoft Word 2000 
   

1.  On the Tools menu, click Customize and then click the Options tab. Set the Menu animations option to 
None.  

2.  On the Tools menu and then click Customize. Remove the Detect and Repair command from the Help 
menu.  

3.  On the Tools menu, click Options, and then click the General tab. Clear the Provide feedback with 
animation and Provide feedback with sound check boxes.  

4.  On the Tools menu, click Options, and then click the Spelling and Grammar tab. Clear the Check 
grammar as you type  check box.  

After you customize all the application settings you want, run the Profile Wizard and save your settings in an OPS 
file. Store the OPS file in a folder that is accessible to users running Office from the Terminal Server computer.  
To point users to your customized settings  

1.  On the Start menu, click Run, and type regedit.exe to open the Windows Registry Editor.  
2.  Create a new subkey named RunOnce in the following subkey:  
 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal 

Server\ Install\Software\Microsoft\Windows\Current Version  
3.  In the RunOnce subkey, create a new entry with a string value and any value name.  
4.  Set the value of the new entry to the following:  

 path\Proflwiz.exe /r file /q  
 where path is the fully qualified path to the Profile Wizard, and file is the file name and fully qualified path to 

the OPS file you created.  



When users log on to the Terminal Server computer, Windows runs the Profile Wizard using the command line in 
the RunOnce subkey and restores the settings you saved in the OPS file. This command runs one time for each 
user the first time the user logs on to the Terminal Server computer.  

Configure Microsoft Outlook 2000 
   

To complete the installation of Outlook 2000, you need to perform two additional steps after running Office Setup. 
First: run Outlook 2000 once; and second, optionally provide write access to a portion of the Windows registry. 

Outlook 2000 performs a number of initialization tasks when it runs for the first time on the Terminal Server 
computer. These tasks complete the Outlook installation and require write access to system areas on the 
Terminal Server computer.  

To allow Outlook to finish installing  
1.  Before any user runs Outlook on the Terminal Server computer, log on to the Terminal Server computer as 

the administrator.  

2.  Run Outlook.  
 Outlook completes any remaining installation tasks.  
3.  Exit Outlook.  

By default, users have write access to all portions of the Windows registry on the Terminal Server computer. 
However, if you have any custom Outlook forms installed on the computer, and you have configured the 
Windows registry on the Terminal Server computer to restrict user access, then you need to make sure that 
users have write access to the HKEY_CLASSES_ROOT\CLSID key in the Windows registry.  
Outlook registers custom forms the first time that they are opened, and this requires that the user have write 
access to this portion of the registry. 

To give users write access to the CLSID key  
1.  Log on to the Terminal Server computer as the administrator.  
2.  On the Start menu, click Run.  

3.  Type regedt32.exe and click OK.  
4.  In the HKEY_CLASSES_ROOT window, select CLSID.  
5.  On the Security menu, click Permissions.  

6.  In the Registry Key Permissions dialog box, select the Replace Permission on Existing Subkeys check 
box, and then click Add.  

7.  In the Name box, click Everyone, click Add, and then click OK.  

 If you do not want to give all users this access, you can add specific users or groups of users in the Names 
box, rather than selecting Everyone.  

8.  In the Type of Access box, select Special Access, and then select the Query Value, Set Value , and 
Create Subkey check boxes.  

9.  Click OK and close the Registry Editor.  
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